Multiprotocol Label Switching (MPLS) Overview

The traditional router-based network connects each peer site through dedicated point-to-point links or leased lines. That approach is expensive, not scalable, and requires long and difficult deployment, although it promises a completely secure and reliable connection, high bandwidth, good quality of service. Another alternative that emulates the point-to-point links is by using Multi-Protocol Label Switching (MPLS) services with the same and improved quality of service.

 

Virtual Private Network (VPN) Models

VPN can be implemented based on two models:

• Overlay Model

The local ISP provides a virtual point-to-point link between customers. Commonly used overlay VPNs are IPSec, GRE, and frame relay.

• Peer-to-peer Model

The local ISP participates in the customer routing. A common example of a peer-to-peer model is MPLS.

 

What is Multi-Protocol Label Switching (MPLS)?

MPLS is a method of forwarding IP packets by using labels instead of IP addresses or layer 3 packet headers. It combines the best characteristics of the Overlay and Peer-to-peer model. Because it uses labels, it speeds up packet forwarding and IP routing. It removes the processing load of IP inspection when using a normal routing operation.

 

MPLS Operation

On a normal routing operation, the router receives the packet, checks the layer 3 header, and gets the destination IP address to decide which path the packet should go. The router always checks the routing table in forwarding the packet. On an MPLS network, the router only checks on the label, which reduces the overhead processing and boosts the speed of the network.

 

The below diagram shows how labels are transferred on each router.

mpls

 

NOTE
Label Switched Paths (LSPs) are predetermined and unidirectional paths between the MPLS routers. When a packet arrives the network through a Label Edge Router, also known as an “ingress node”, it is allocated to a Forwarding Equivalence Class (FEC), depending on the type of data and its intended IP addresses, either IPv4 or IPv6, to identify endpoints and intermediate switches and routers.

 

The below diagram shows the MPLS networks. The customer edge router (CE) route traffic to Provider Edge (PE) routers, and each router has its own isolated routing table instance on the PE router. The core routers do not have customer route information. The label switching is enabled in ISP core routers.

mpls network

 

NOTE
Penultimate Hop Popping (PHP) removes the requirement for the double lookup to be performed on an egress router (PE). It optimizes the MPLS performance.

 

MPLS LDP Configuration

MPLS does not forward the label automatically. It uses Label Distribution Protocol (LDP) to share labels on every router within the ISP core network. We will use the below network diagram for our configuration example.

mpls configuration

 

1. Configure the IP address on each interface and the IP address for loopback 0. Configure the interior gateway protocol (IGP) on each router and advertise each route on the network.

Router1:

conf t
int g0/0
ip address 10.1.1.1 255.255.255.0
no shut
ip ospf 1 area 0
int lo0
ip address 1.1.1.1 255.255.255.0
no shut

 

Router2:

conf t
int g0/1
ip address 10.1.1.2 255.255.255.0
no shut
ip ospf 1 area 0
int g0/0
ip address 20.1.1.2 255.255.255.0
no shut
ip ospf 1 area 0
int lo0
ip address 2.2.2.2 255.255.255.0
no shut

 

Router3:

conf t
int g0/1
ip address 20.1.1.1 255.255.255.0
no shut
ip ospf 1 area 0
int g0/0
ip address 30.1.1.1 255.255.255.0
no shut
ip ospf 1 area 0
int lo0
ip address 3.3.3.3 255.255.255.0
no shut

 

Router4:

conf t
int g0/0
ip address 30.1.1.2 255.255.255.0
no shut
ip ospf 1 area 0
int lo0
ip address 4.4.4.4 255.255.255.0
no shut

 

3. Check if Cisco Express Forwarding is enabled on each router.

 Router#show ip cef

 

4. Configure LDP on each router.

Router(config)#mpls label protocol ldp
Router(config)#mpls ldp router-id loopback 0

 

5. Activate MPLS in each router’s interface.

Router(config)#interface <interface #>
Router(config-if)#mpls ip
Router(config-if)#end

 

6. The below show command will be used to verify that packets are forwarded based on label lookup.

Router#show mpls neighbor
Router#show mpls interfaces
Router#show mpls ldp bindings

Download our Free CCNA Study Guide PDF for complete notes on all the CCNA 200-301 exam topics in one book.

We recommend the Cisco CCNA Gold Bootcamp as your main CCNA training course. It’s’ the highest rated Cisco course online with an average rating of 4.8 from over 30,000 public reviews and is the gold standard in CCNA training: