Cisco Layer 3 EtherChannel – Explanation and Configuration

You probably learned about Layer 2 EtherChannels and how to configure them. Now, we are going to discuss EtherChannel on Layer 3 switches and how to configure it.

One use case on why we would want to configure EtherChannel on Layer 3 switches is when we are forming redundancy between Core and Distribution Layers and implementing a routing protocol. Instead of learning two IP routes with the same neighboring switch (but two different next hops), we now can have a single next-hop IP address of the neighboring switch for each IP route learned.

Another use case is to avoid Spanning Tree Protocol (STP) and use Layer 3 links between your Core and Distribution Layers instead. We can enable routing protocols where we can have more control on load balancing and failover and can be much faster than STP.

 

NOTE
1. The port-channel interface number can differ between two neighbor Layer 3 Switches, but we have to use the same Channel Group Number for all physical interfaces on a Layer 3 Switch.
2. We have to issue the ‘no switchport’ command to make the physical interface a routed port/interface (Group state = from Layer 2 to Layer 3)

 

Layer 3 EtherChannel Configuration

For the Layer 3 Etherchannel configuration, we will use the topology below as an example. We have two Layer 3 switches, Switch1 and Switch2, and we will configure the two links connecting them as EtherChannels.

layer 3 etherchannel

 

Switch1 Configuration:

Switch1(config)#interface range FastEthernet 0/1 - 2
Switch1(config-if-range)#no switchport
Switch1(config-if-range)#channel-group 1 mode desirable
Switch1(config-if-range)#interface port-channel 1
Switch1(config-if)#no switchport
Switch1(config-if)#ip address 192.168.1.1 255.255.255.0

 

Switch2 Configuration:

Switch1(config)#interface range FastEthernet 0/1 - 2
Switch2(config-if-range)#no switchport
Switch2(config-if-range)#channel-group 2 mode desirable
Switch2(config-if-range)#interface port-channel 2
Switch2(config-if)#no switchport
Switch2(config-if)#ip address 192.168.1.2 255.255.255.0

 

Layer 3 EtherChannel Verification

We can verify if our layer 3 EtherChannel configuration is working as expected by doing the following commands:

First, let’s check if we can ping between point-to-point links.

Pings from Switch1 to Switch2

Switch1#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 2/3/5 ms

 

Pings from Switch2 to Switch1

Switch2#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/3/4 ms

 

We can also check the Group state using the ‘show etherchannel‘ command in the global configuration mode:

Switch1#show etherchannel
Channel-group listing:
----------------------
Group: 1
----------
Group state = L3
Ports: 2 Maxports = 4
Port-channels: 1 Max Port-channels = 1
Protocol: PAgP
Minimum Links: 0

 

To check the Port-channel status, we can use the ‘show etherchannel port-channel‘ command:

Switch1#show etherchannel port-channel
                Channel-group listing: 
                ----------------------
Group: 1 
----------
                Port-channels in the group: 
                ---------------------------
Port-channel: Po1
------------
Age of the Port-channel   = 0d:00h:40m:39s
Logical slot/port   = 16/0          Number of ports = 2
GC                  = 0x00010001      HotStandBy port = null
Passive port list   = Fa0/1 Fa0/2 
Port state          = Port-channel L3-Ag Ag-Inuse 
Protocol            =   PAgP
Port security       = Disabled
Ports in the Port-channel: 
Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Fa0/1    Desirable-Sl       0
  0     00     Fa0/2    Desirable-Sl       0
Time since last port bundled:    0d:00h:35m:01s    Fa0/2

Download our Free CCNA Study Guide PDF for complete notes on all the CCNA 200-301 exam topics in one book.

We recommend the Cisco CCNA Gold Bootcamp as your main CCNA training course. It’s the highest rated Cisco course online with an average rating of 4.8 from over 30,000 public reviews and is the gold standard in CCNA training: