Lightweight Access Point (AP) Configuration

Wireless Access Points (WAP) provide wireless connectivity to a wired network. We can use two access point modes of operations in wireless network deployment, Autonomous Access Point and Lightweight Access Point (LAP). Unlike Autonomous Access Points, Cisco Lightweight Access Points need Wireless Lan Controllers (WLC) to function fully. LAP and WLC form a CAPWAP tunnel that carries control and data traffic.

 

Lightweight Access Point Configuration

Let’s start with the L3SW. We will create VLAN 10 for the administrator to manage WLC and VLAN 11 for the CAPWAP traffic between the Lightweight Access Points and WLAN. Then, we will also add Guess and Corporate VLANs that the WLC will use:

L3SW(config)#vlan 21
L3SW(config-vlan)#name Corporate
L3SW(config)#vlan 22
L3SW(config-vlan)#name Guess
L3SW(config)#vlan 10
L3SW(config-vlan)#name WLC-Management
L3SW(config)#vlan 11
L3SW(config-vlan)#name AP-Management

 

We then need to configure the trunk port on the link between WLC and L3SW to propagate multiple VLANs on that link.

L3SW(config)#interface FastEthernet 0/5
L3SW(config-if)#switchport trunk encap dot1q
L3SW(config-if)#switchport mode trunk 
L3SW(config-if)#switchport mode trunk allowed vlan 10,11,21,22

 

After that, we’ll configure the interface connected to the Lightweight AP as an access port in the AP management VLAN.

L3SW(config)#interface FastEthernet 0/2
L3SW(config-if)#switchport mode access
L3SW(config-if)#switchport access vlan 11

 

Let’s move to SW2 to configure trunk and access ports for PC1 and PC2 management access.

SW2(config)#interface FastEthernet 0/1
SW2(config-if)#switchport trunk encap dot1q
SW2(config-if)#switchport mode trunk 
SW2(config)#interface FastEthernet 0/2
SW2(config-if)#switchport trunk access
SW2(config-if)#switchport access vlan 10
SW2(config)#interface FastEthernet 0/3
SW2(config-if)#switchport trunk access
SW2(config-if)#switchport access vlan 11

 

Lightweight Access Point Traffic Flow

When the wireless client, Guess, sends an Ethernet frame destined to PC2, the frame will traverse on the CAPWAP tunnel, and the WLAN will tag it to the associated VLAN that forwards it to L3SW over the trunk link. After that, the L3SW will send it to SW2, and SW2 will de-encapsulate the tagged Ethernet frame and send it to PC2.

Lightweight Access Point

The blue arrow shows the traffic flow of an untagged frame sent by Guess users over the access links, while the red arrows are the flow of tagged frames over the trunk links. The Lightweight AP and WLC form a CAPWAP logical tunnel, colored green in the above image, bypassing the network devices between them. The CAPWAP tunnel enables sending data and control traffic to the Cisco Wireless LAN Controller (WLC) across the tunnel seamlessly.


Download our Free CCNA Study Guide PDF for complete notes on all the CCNA 200-301 exam topics in one book.

We recommend the Cisco CCNA Gold Bootcamp as your main CCNA training course. It’s the highest rated Cisco course online with an average rating of 4.8 from over 30,000 public reviews and is the gold standard in CCNA training: