EIGRP Configuration

Configuring EIGRP 1

EIGRP configuration closely resembles RIP configuration. Only two steps are required:

  • enabling EIGRP by using the router eigrp ASN_NUMBER command
  • telling EIGRP which networks to advertise by using one or more network statements

The first command, router eigrp ASN_NUMBER, enables EIGRP on a router. ASN_NUMBER represents an autonomous system number and has to be the same on all routers running EIGRP, otherwise routers won’t become neighbors. The second command, network SUBNET, enables EIGRP on selected interfaces and specifies which networks will be advertised. By default, the network command takes a classful network number as the parameter.

To illustrate a configuration of EIGRP, we will use the following network:

eigrp sample topology

The network depicted above consists of only two routers. Each router has a directly connected subnet that needs to be advertised through EIGRP. Here is the EIGRP configuration on R1 and R2:

R1(config)#router eigrp 1
R1(config-router)#network 10.0.0.0
R1(config-router)#network 172.16.0.0
R1(config-router)#

R2(config)#router eigrp 1
R2(config-router)#network 192.168.0.0
R2(config-router)#network 172.16.0.0
R2(config-router)#

You can verify that routers have become neighbors by using the show ip eigrp neighbors command on either router:

R1#show ip eigrp neighbors

IP-EIGRP neighbors for process 1

H Address Interface Hold Uptime SRTT RTO Q Seq

                    (sec) (ms) Cnt Num

O 172.16.0.2 Fa0/0 12 00:01:25 40 1000 0 3

The command above lists all EIGRP neighbors. The address field lists the neighboring router RID (router ID). The interface field shows on which local interface the neighbor relationship has been formed.

You can verify that routes are indeed being exchanged by using the show ip route command on both routers:

R1:

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, FastEthernet0/1
C 172.16.0.0/16 is directly connected, FastEthernet0/0
D 192.168.0.0/24 [90/30720] via 172.16.0.2, 00:00:03, FastEthernet0/0

R2:

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 1 subnets
D 10.0.0.0 [90/30720] via 172.16.0.1, 00:00:02, FastEthernet0/0
C 172.16.0.0/16 is directly connected, FastEthernet0/0
C 192.168.0.0/24 is directly connected, FastEthernet0/1
R2#

 

NOTE
The D character at the beginning of a line in a routing table indicates that the route has been learned via EIGRP.

 

Configuring EIGRP 2

By default, the network command uses a classful network as the parameter. All interfaces inside that classful network will participate in the EIGRP process.To enable EIGRP only on specific interfaces, a wildcard mask can be used. The syntax of the command is:

(router-eigrp) network WILDCARD_MASK

Consider the following example.

eigrp sample topology 2

Router R1 has two directly connected subnets, 10.0.0.0/24 and 10.0.1.0/24. We want to enable EIGRP only on the subnet connected to the interface Fa0/0. If we enter the network 10.0.0.0 command under the EIGRP configuration mode, both subnets will be included in EIGRP process because we’ve used a classful network number in the network command. To configure EIGRP only on interface Fa0/0, the network 10.0.0.0 0.0.0.255 command can be used. This will enable EIGRP only on interfaces starting with 10.0.0.X.

R1(config)#router eigrp 1
R1(config-router)#network 10.0.0.0 0.0.0.255
R1(config-router)#

By using the command show ip protocols, you can verify that only the network 10.0.0.0/24 is included in  EIGRP:

R1#show ip protocols

Routing Protocol is "eigrp 1 "
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
Redistributing: eigrp 1
EIGRP-IPv4 Protocol for AS(1)
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum metric variance 1
Redistributing: eigrp 1
Automatic network summarization is in effect
Automatic address summarization: 
Maximum path: 4
Routing for Networks:
10.0.0.0/24
Routing Information Sources:
Gateway Distance Last Update
Distance: internal 90 external 170
R1#

Download our Free CCNA Study Guide PDF for complete notes on all the CCNA 200-301 exam topics in one book.

We recommend the Cisco CCNA Gold Bootcamp as your main CCNA training course. It’s the highest rated Cisco course online with an average rating of 4.8 from over 30,000 public reviews and is the gold standard in CCNA training: